fix dependency vulns: bump next 16.3.8 (RCE), override brace-expansion, vendor patched braces 3.0.4
This commit is contained in:
parent
662b60749d
commit
e1250120b1
16 changed files with 1764 additions and 77 deletions
16
package.json
16
package.json
|
|
@ -1,6 +1,6 @@
|
|||
{
|
||||
"name": "dvorakmortonxd",
|
||||
"version": "2.2.6",
|
||||
"version": "2.2.7",
|
||||
"private": true,
|
||||
"scripts": {
|
||||
"dev": "node scripts/dev-server.mjs",
|
||||
|
|
@ -10,7 +10,7 @@
|
|||
"lint": "eslint"
|
||||
},
|
||||
"dependencies": {
|
||||
"next": "^16.3.5",
|
||||
"next": "^16.3.8",
|
||||
"react": "^19.3.0",
|
||||
"react-dom": "^19.3.0"
|
||||
},
|
||||
|
|
@ -22,12 +22,22 @@
|
|||
"@types/react-dom": "^19.3.0",
|
||||
"autoprefixer": "^10.6.0",
|
||||
"eslint": "^9.39.5",
|
||||
"eslint-config-next": "^16.3.5",
|
||||
"eslint-config-next": "^16.3.8",
|
||||
"fill-range": "^7.1.1",
|
||||
"postcss": "^8.5.28",
|
||||
"tailwindcss": "^4.3.3",
|
||||
"typescript": "^5.9.3"
|
||||
},
|
||||
"allowScripts": {
|
||||
"unrs-resolver@1.12.2": true
|
||||
},
|
||||
"overrides": {
|
||||
"minimatch@^3.0.0": {
|
||||
"brace-expansion": "1.1.21"
|
||||
},
|
||||
"minimatch@^10.0.0": {
|
||||
"brace-expansion": "5.0.12"
|
||||
},
|
||||
"braces": "file:vendor/braces"
|
||||
}
|
||||
}
|
||||
|
|
|
|||
Loading…
Add table
Add a link
Reference in a new issue